That’s my blog… Life and Linux

Un’aMule tira l’altro. Eccoci alla 2.1.3!

aMule logoPare che agli sviluppatori di aMule, sia venuta voglia di rilasciare versioni stabili a raffica, infatti è stata appena resa pubblica la nuova versione di aMule, la 2.1.3.
Anche quiesta, come le due precedenti della serie 2.1.x, è solo una release di bugfix, non vi sono pertanto nuove caratteristiche. Le correzioni (piuttosto poche in termini numerici) si sono orientate più che altro sul lato della localizzazione. È stato inoltre creato (ma non aggiunto alla release) uno script (in perl) per importare i files temporanei di MlDonkey. Se siete interessati ai vari fix, vi rimando al changelog completo.

Per la compilazione tramite sorgenti fate riferimento al post sulla versione 2.1.0, mentre per gli utenti ubuntu-dapper (e ovviamente Kubuntu :)), ho preparato due nuovi pacchetti, uno “standard”, mentre l’altro compilato con ottimizzazioni per i processori «686». Li potete scaricare dai link sottostante:

Le stringhe di compilazione che ho usato (al di là delle ottimizzazioni) abilitano le seguenti feature:

./configure –prefix=/usr –mandir=\${prefix}/share/man –infodir=\${prefix}/share/info –enable-optimize –enable-amule-daemon –enable-amulecmd –enable-webserver –enable-amule-gui –enable-wxcas –enable-alc

Ho inoltre cambiato, anche in questa versione, l’icona di aMule usata nei menù e nel desktop perché, quella originale ha una risoluzione bassa e, almeno a me, appare come "deforme" 🙂

Siccome, dal 1° giugno sono passato a Dapper, non so se questo pacchetto possa funzionare sulla distribuzione «breezy», provate e fatemi sapere…! Se servisse posso modificare il pacchetto.

Bye! :bye:

  • smurf

    Grazie trevino per la tua segnalazione, ma il pacchetto di amule per amd 64 ce l’ ho già. sono le wxgtk2.6.3 he non trovo per amd64.

    Ho provato ad installare il pacchetto che mi hai segnalato, ma  quando parte mi dice sempre che è basato su wxGTK2.6.1 Unicode (che ho installato sul mio pc).

    Ciao 

  • fabian

    Ciao! volevo sapere se su questa nuova versione c’è questo “Protocollo di Offuscamento” del qualle parla questo link. Io ho la versione 2.1.0 che non cel’ha e siccome tutto funziona ok non vorrei aggiornare per questo e dopo vedere che non c’è.
    Grazie.

    http://www.megalab.it/articoli.php?id=885

  • @smurf non ho capito il problema… Cosa chi e cosa ti dice? non parte? 😮 

    @fabian No, non è ancora presente… Verrà incluso presumibilmente nella 2.2.0, ma ancora non abbiamo tempi di rilascio a disposizione…

    Ciao! 😉 

  • smurf

    allora. il problerma è che a me amule crasha di continuo, e sul forum di amule dicono che è colpa delle wxgtk che ho installate che sono la 2.6.1. Per risolverli devo installare le wxgtk 2.6.3, ma per amd 64 non le trovo.

    Il pacchetto che mi hai segnalato parte e funziona per un po, come tutti gli altri che ho provato, poi crasha quasi sempre con il messaggio "BadDrawablePicture".

    Per inciso… il pacchetto che ho scaricato dal sito di methu ha già la opzione di offuscamento.

    Ciao 

  • Ah, buono evidentemente è stato aggiunto ai cvs… vorrà dire che mi pacchettizzerò pure quello…

    Hai provato sennò a farti il pacchetto da solo? 

  • Rospo

    Problema; nn mi completa i file di grosse dimensioni con l 2.1.3!!!

    La 2.1.0 sembra andare bene!!!

    Scarica circa il doppio della dimensione reale del file senza mai riuscire a finalizzarlo!!!

    Help me!!! 

  • Propbabilmene dipende dal file più che dalla release… Magari è un file corrotto messo in circolazione da gente un po’ “strana” che cerca di «insudiciare» le fonti buone…

    Vedi se lo fa con tutti i file o se avviene solo con un file specifico 

  • Rospo

    E’ un problema generale che fa con tutti i file di grosse dimensioni e solo su linux, con emule per winxp gli stessi file li scarica bene

  • Marildo

    Perdona, sono brasiliano e non parlo italiano.
    O aMule 2.13 está trabalhando muito bem aqui comigo.
    Grazie.

  • Obrigado para o amule downloading e suportando! 😉

    [I hope that babelfish has done a good job :p] 

  • Oz

    Va come una scheggia ! emoticon

  • lucifercheff

    Broken links. Please fix it.

  • tw_ffm

    Hi there ..

    Just two working links for all of you:

  • tw_ffm
  • lucifercheff

    thanks 😉

  • FUNZIONAAAA.

     I’ve made only one change. My source.list file in APT dir and "et voilà"..

    apt-get update

    apt-get upgrade

     that’s all..

    thank you guys.. grat job.

    ==================================================

    Ho fatto solo una modifica al sources.list e aggiornato tramite APT-GET.

    Ha fatto tutto lui senza problemi..

    Bravi, sono felice che quando gli italiani ci si mettono non ce n’è per nessuno..

    ciao a tutti e grazie.

    Antony 

  • Silvio

    ciao a tutti,

    uso ubuntu 6.\0 e noto una cosa strana con amule, ogni volta che faccio una ricerca e poi la chiudo mi si chiude anche amule….

     è un bug o è un problema mio?

     grazie mille

     ciao

  • No, dovrebbe essere un bug conosciuto 🙁  

  • danovic

    io lavoro con un mac e non trovo niente che lui non supporta, passate con lui e troverete la differenza in meno di un giorno…..emoticon

  • Socket

    Salve a tutti!

    Io uso Ubuntu 6.06 Dapper Drake…bhe, apparte che dal sito ufficiale di amule, non si può scaricare nulla di nulla…non chiedetemi il perchè, ma ogli qual volta che tento di scaricare qualche paccheto, mi viene fuori "file non trovato". Cmq torniamo a noi; ho scaricato il pacchetto "amule_2.1.3-3v1-2ubuntu1dapper3_i386.deb" ma mi appare questo problema: Error: Dependency is not satisfiable: libwxgtk2.6-0. Ora, io non so proprio che fare (scuaste ma sono anche ignorantello di mio…uso Ubuntu da 5 ore, e sono solo riuscito ad aggiornare Lingue, Firefox, Configurare Rete, Amsn). Da quello che ho capito, ci sono dei problemi di compilazione del file, quindi bisogna scaricare un paccheto che il mio fido Ubuntu non ha in Synaptic (già ho controllato tutto..). Quindi se potreste aiutrmi linkandomi i file che mi servono (occhio che fungono, sul sito di amule non funge nulla) e spiegandomi passo passo quello che dovrei fare…mi fareste un super piacere! Grazie!

  • Guarda, installa quel pacchetto con sudo apt-get install libwxgtk2.6-0 -f quindi reinstalla il pacchetto… (Comunque puoi anche installarlo da synaptic se hai una sources.list a posto ;))

  • Riccardo

    a me ha fatto così: ho installato tutti i pacchetti poi ho lanciato il deb. se avvio mi da questo 

     

    amule: Symbol `_ZTI7wxSizer’ has different size in shared object, consider re-linking
    Fatal Error: Mismatch between the program and library build versions detected.
    The library used 2.6 (no debug,Unicode,compiler with C++ ABI 102,wx containers,compatible with 2.4),
    and your program used 2.6 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.4).
    Aborted

  • Usi edgy? Nel caso installa la versione per la tua distro…

  • Riccardo

    Si uso Edgy…scusa trevino della mia ignoranza, ma dove posso trovare la versioneper edgy che sto diventando scemo…???? c’è un .deb per la mia versione di kubuntu?

  • Inserisci il mio repository nella sources.list quindi segui l’aggiornamento ed avrai l’ultimo amule tra le tue mani 🙂

  • Riccardo

    trevino sono un cerebroleso, ho la 6.06 perchè la 6.10 non mi si installava. sai ho il muletto con il quale mi diverto tanto che é un p2 200, con 196 di ram e una vga 16mb..insomma un cesso e la edgy non mi partiva. solo che quel problema di errore con amule me da lo stesso…le ho provate tutte, inoltre se vado a fare un apt-get install mi dice che manca la "libcrypto+**,** (gli asterischi sono dei numeri che non ricordo) non so più come risolvere e vorrei avere il mulo anche sul pinguino…io è da un anno che uso linux, ma non sono ancora molto pratico.

  • Riccardo

    forse ci sono ho installato tutti gli altri pacchetti amule-common etc..adesso però mi esce:

     

    Il server HTTP ha inviato un header di risposta non valido Impossibile ottenere http://3v1n0.tuxfamily.org/pool/dapper/3v1n0/amule_2.1.3-3v1-2ubuntu1dapper3_i386.deb Il server HTTP ha inviato un header di risposta non valido E: Impossibile prendere alcuni archivi, forse è meglio eseguire apt-get update o provare l’opzione –fix-missing

  • L’indirizzo del repository è cambiato… Modifica la tua sources list come indicato qui: http://3v1n0.tuxfamily.org/ 😉

  • ciao sai se le tue versioni funziano su ubuntu 7.04 desktop? non riesco a far funzionare amuleweb…

  • Bhe, lo uso su quello a me funzionano tutti i tool correlati…

  • mattia

    ciao io ho scaricato la tua versione 1386. la lancio ma mi dice :

    dependency is not satisfable :  libwxgtk2.6-0

     

    cosa devo fare per risolvere? 

  • Ci sono versioni per feisty più recenti nel mio repository 3v1n0.