That’s my blog… Life and Linux

Uscito aMule 2.1.1

aMule LogoCiao, news di fretta 😮 oggi, per notificarvi l’uscita della nuova versione di aMule, la 2.1.1.
È come dicono gli sviluppatori è solo una release di bugfix, non è stato aggiunto il supporto per i files più grandi di 4GB (che invece è presente nelle «versioni CVS»), mentre è stato aggiornato l’indirizzo del server.met, non più funzionante (changelog completo).

Per la compilazione tramite sorgenti fate riferimento al post sulla versione 2.1.0, mentre per gli utenti ubuntu (e ovviamente Kubuntu :)), ho preparato un nuovo pacchetto, lo potete scaricare dal link sottostante:

EDIT 29/03/2006:
    Aggiornato il pacchetto aMule, adesso viene installato in /usr/* invece che in /usr/local/*.

CIAO! 😛 

PS: Mi auguro di integrare nelle prossime ore il post, ma per ora la fretta mi assale… 😮

  • Thanks, works fine.

  • Che bravo schiavetto provetto, gh.. emoticon

    Così posso lasciare a riposo gcc ancora per qualche altro minuto.. emoticon

     OT >> ma tinymce è proprio necessario nei commenti? Mi sborda di una sciamannata di pixel dentro al menù di destra 😀

     Alla prox 😉

  • Mh… Davvero?
    In tutti i PC che ho visto ora va bene… Prima aveva dei problemi poi credevo di aver risolto.
    Mi mandi uno screenshot please (mail trevi55 at gmail dot com)? Che risoluzione hai? Perché per ora non ho notato problemi su nessuna configurazione 😮

    Ciao!

  • si trevi, cmq anche a me sborda l’editor…

    e la mia configurazione la sai .. risoluzione 1024×768 

  • 🙁

    Non so che farci… qui varia… Non ho idea di come renderlo più o meno fisso :|. Se qualcuno può aiutarmi…     

  • Come aggiornare da 2.1.1?

    Ciao grazie per il pacchetto,

    sono un novizio di ubuntu e non so come fare per passare alla 2.1.1 (ho la 2.1.0 installata): che cosa si deve fare, disinstallare la vecchia e reinstallare (se sì, come?) sovra-installare? o…

    grazie

    emoticon 

  • Il precedente deb della 2.1.0 mi dava un fastidioso problema: dopo qualche tempo (>~ 10′ ) l’uso della cpu schizzava al cento per cento. Risolsi compilandomi aMule a manina.

    Ora scarico il deb nuovo e domani provo. Per favore puoi  mettere le opzioni che hai passato in compilazione?

    Thx 

  • mario

    Scusate, forse questo non è il posto giusto dove postare questa mia richirsta ma spero comunque che qualcuno mi riponda

    Sono un novizio per quanto riguarda LINUX e ho installato Ubuntu 5.10

    Ho anche installato il pacchetto di amule 2.1.0

    Apparentemente l’installazione è andata a buon fine tanto che all’interno del menù Applicazioni—–Internet

    c’è l’icona di amule……..Il probroblema è che se ci clicco non si pre assolutamente nulla

    cosa posso fare 

  • sono un novizio di ubuntu e non so come fare per passare alla 2.1.1 (ho la 2.1.0 installata): che cosa si deve fare, disinstallare la vecchia e reinstallare (se sì, come?) sovra-installare? o…

    Il pacchetto lo installi con sudo dpkg -i amule_2.1.1-0ubuntu1_i386.deb

    Il vecchio verrà sostituito.

    Ho anche installato il pacchetto di amule 2.1.0

    Apparentemente l’installazione è andata a buon fine tanto che all’interno del menù Applicazioni—–Internet

    c’è l’icona di amule……..Il probroblema è che se ci clicco non si pre assolutamente nulla

    Riguardo l’icona, se guardi il post precedente su aMule 2.1.0, troverai tra i commenti il modo per modificare il menù di GNOME, avendo compilato questo pacchetto sotto KDE, il collegamento non potrebbe essere stato fatto correttamente.

    Il precedente deb della 2.1.0 mi dava un fastidioso problema: dopo qualche tempo (>~ 10′ ) l’uso della cpu schizzava al cento per cento. Risolsi compilandomi aMule a manina.

    Ora scarico il deb nuovo e domani provo. Per favore puoi  mettere le opzioni che hai passato in compilazione?

    Nel caso in cui ci fossero problemi, fammi risapere. Ho usato la stessa striga di compilazione della versione 2.1.0:

    ./configure -–enable-optimize –-enable-amule-daemon –-enable-amulecmd -–enable-webserver –-enable-amule-gui –-enable-wxcas –-enable-alc

    Ciao!

     

  • kochab

    grazie,

    io ho ubuntu breezy e funziona benissimo!

    volevo chiedere una cosa, io avvio amule con la gui e poi mi connetto via ssh da remoto e vorrei controllarlo attraverso amulecmd, qualcuno lo ha mai usato?

    ciao 

  • Easyfunk

    Thanks a lot!
    Works really fine!

  • aMulecmd non l’ho mai usato a dire il vero… ho guardato l’–help e non mi pare niente di difficile, però non ho provato da altre macchine…

    Appena provo vi faccio sapere.     

  • Ho fatto girare la 2.1 per una trentina di ore non e non c’è più il problema che ho segnalato qualche commento sopra.

  • Benone 🙂

    Io la uso da un po’ mi pare molto più stabile della 2.1.0 😉     

  • seb

    Merci Beaucoup

    grazie mille 

  • De rien… 🙂  

  • Mikelone

    scusate se rompo ma non riesco ad installare amule 2.1.1 perchè mi manca una dipendenza precisamente libwxgtk2.6-0 e non la trovo da nessuna parte come faccio??emoticon

     

  • Sicuro di avere i repository a posto? 🙄

    La scarichi da qui: http://packages.ubuntu.com/breezy/libs/libwxgtk2.6-0 però eventualmente dei repository aggiornati e completi li trovi sul link in alto a destra di questo blog 😉 

  • stc

    salve, scusami Treviño ma sul tuo http://packages.ubuntu.com/breezy/libs/libwxgtk2.6-0 solo per la dapper si trova la versione richiesta…
    –dapper (libs): wxWidgets Cross-platform C++ GUI toolkit (GTK+ runtime) [universe]
    2.6.1.2ubuntu2: amd64 i386 powerpc

    come fare allora ?

  • Ah, un problema di versione?

    Mh… Semmai sistemo il pacchetto. Tu che versione hai?     

  • Mikelone

    Grazie Trevi non saprei come fare senza di te

     

  • Marco

    Intanto grazie veramente di cuore per il tuo blog! Appena scoperto è immediatamente e definitivamente finito fra i miei bookmarks, e non solo per i contenuti informatici! Per quanto riguarda il pacchetto di amule, con la tua penultima release mi ero trovato benone, ma quest’ultima anch’io non riesco ad installarla (su breezy) a causa di un problema di dipendenze riguardo a libwxgtk2.6-0. Ciao e grazie ancora!

  • Grazie per i complimenti :P. 

    Mhmhm… Mi sa che ho un pacchetto “troppo” aggiornato :P.

    Ho sistemato le dipendenze… Riscaricate il pacchetto, ora dovrebbe essere ok 🙂

    In ogni caso fatemi sapere! 😉 

  • stc

    Grazie! 😉 ora tutto funziona!!! 😉

     

     Ottimo lavoro!

     

    continuate così 😉

    trevino di XGL che mi dici ? :PPP

    io ne sono rimasto shokkato ;D

    bye bye 

  • Le XGL sono spettacolo…
    C’ho passato 2 ore a giocare con le finestre :D, solo che per usarle noi ubuntiani dobbiamo attendere la dapper (anche se per gli utenti gnome c’è un modo anche per breezyITA).

    Ho provato a metterlo in KDE ma non riesco… Non mi ci sono sbattuto troppo… Aspetterò un altro po’… 🙂

    Ciao!

  • Marco

    Mi unisco ai ringraziamenti! Ciao!

  • EMANUEL

    SALVE A TUTTI………….SONO NUOVO,HO DA PORRE UN PROBLEMA……..TENTANDO  DI INSTALLARE LA  NUOVA  VERSIONE DI amule 2.1.1ubuntu1breezy1…….MI DA ERRORE DI (PIPE ROTTA) AIUTATEMI NON SO COSA FARE!!!!

  • Mhmhmh…. Prova a riscaricare il file, magari si è corrotto…

    Eventualmente fai

    md5sum amule_2.1.1-2ubuntu1breezy1_i386.deb

    Vedi se ti restituisce il mio stesso valore (fbf395548def5331381ee6658350ac41).

    Ciao!

  • EMANUEL

    ho fatto il procedimento di verifica consigliatomi ………..ed è tutto ok il numero combacia perfettamente…………..mi da sempre  sta (pipe rotta)non so che pesci prendere perchè non mi è mai capitato……..non so magari sbaglio qualcosa durante l’installazione(anche se non penso)…………..se mi fai il favore di scrivermi i comandi anche te………….mi tolgo sto dubbio…………………..grazie x la pazienza……….salutoni

  • Basta fare dpkg -i nomepacchetto.deb

    Boh… 😮 

  • EMANUEL

    Bene allora non sono (rinco……..)chiaramente prima di fare il comando da te suggerito entro nella directory dove ho salvato il file scaricato…………giusto?

    poi faccio sto benedetto dpkg…….<il listato che segue è la descrizione che genera il pc chiaramente ho accorciato le nomenclature ordinarie ricorrenti>…Mi preparo a sostituire……………………………………………………………..

    Spacchetto il rimpiazzo……………………………………………

    dpkg:errore processando amule_2.1.1………..(–install):

    tentata sovrascrittura di /usr/bin/wxcas’ ,che si trova nel pacchetto amule utils

    dpkg-deb: il sottoprocesso paste è stato terminato dal segnale (pipe rotta)

    Sono occorsi degli errori processando:

    amule_2.1.1………….. 

     Sapresti darmi una mano?

  • EMANUEL

    emoticon

  • sudo dpkg install -f

    Altrimenti solo

    sudo dpkg -r amule-utils

    Quindi reinstalla il pacchetto amule…  

  • EMANUEL

    Bene ora mi da problemi su delle dipendenze……….

    amule: Dipende: libgcc1(>=1:4.0.0)ma 1:4.0-0-opre6ubuntu7 è installato

                Dipende:libstdc++6 (>= 4.0.0) ma non è installato

                Dipende:libwxgtk2.6-0 (>= 2.6.0.0)ma non è installabileemoticon

  • vai ancora con il

    sudo dpkg install -f

  • LYBRA80

    non va non va non va!ok ora vado al trabaco……………emoticon

  • Bob-Shal

    Thanks for your time:) really useful. Have a nice day:)

  • AndreaRX

    Ciao,visto che il tuo pacchetto funzionava bene su Breezy,ho provato ad installarlo su Dapper ma ci sono problemi con le dipendenze (OVVIAMENTE !!!).

    A quando una versione per Dapper ? Magari  un repository da aggiungere al  sources.list !!!

    Grazie per il  prezioso lavoro che fai per la Community .

    Ciao Andrea emoticon 

  • Bob-Shal

    AndreaRX Im using it on dapper without problem !

  • AndreaRX

    Thanks Bob-Shal , this make me think I’m doing something wrong !!!

    This evening I’ll download again the .deb and reinstall it,in order to show you the output of the shell (I’m at work now and … using Winxx)

    Biezz emoticon 

  • Versione per Dapper?

    Beh… Attualmente rimango su Breezy, penso ormai fino alla release, visto che su kubuntu ancora ci sono diverse magagne da mettere a posto, e per ora il sistema mi va benone…

    Cmq sarò pronto presto ;). Penso che sul forum di aMule ci siano dei pacchetti per la Dapper, guardate un po’!     

  • AndreaRX

    Ho installato sulla Dapper (che mi funziona alla grande) i pacchetti .deb trovati sul sito di aMule senza alcun problema di dipendenze,e funzionano veramente benone .

    Ciao alla prossima. 

  • ema92

    Hey mi si è fermato il download…non ho voglia di compilarmelo a mano…ci mette troppo tempo!

  • A me funziona perfettamente… Che dire… Riprova! 🙂

  • Smigol

    Ciao Trevino ma adesso non riesco ad installare aMule prima per la question "su" adesso ho provato sia con il 2.1.0 che con il 2.1.1 e niente lo stesso ti riporto l’errore di seguito magari mi puoi dare dei suggerimenti Grazie

    root@smigol-desktop:/home/smigol# sudo dpkg -i amule_2.1.0-0ubuntu1_i386.deb
    dpkg: errore processando amule_2.1.0-0ubuntu1_i386.deb (–install):
     impossibile accedere all’archivio: Nessun file o directory
    Sono occorsi degli errori processando:
     amule_2.1.0-0ubuntu1_i386.deb
    root@smigol-desktop:/home/smigol# sudo apt-get install -f
    Lettura della lista dei pacchetti in corso… Fatto
    Generazione dell’albero delle dipendenze in corso… Fatto
    0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
    root@smigol-desktop:/home/smigol# sudo dpkg -i amule_2.1.0-0ubuntu1_i386.deb
    dpkg: errore processando amule_2.1.0-0ubuntu1_i386.deb (–install):
     impossibile accedere all’archivio: Nessun file o directory
    Sono occorsi degli errori processando:
     amule_2.1.0-0ubuntu1_i386.deb
    root@smigol-desktop:/home/smigol# sudo dpkg -i amule_2.1.1-2ubuntu1breezy1_i386.deb
    dpkg: errore processando amule_2.1.1-2ubuntu1breezy1_i386.deb (–install):
     impossibile accedere all’archivio: Nessun file o directory
    Sono occorsi degli errori processando:
     amule_2.1.1-2ubuntu1breezy1_i386.deb
    root@smigol-desktop:/home/smigol#     

     poi ho notato che se apro il pacchetto.deb con il doppio clic dal desktop si apre ovviamente "ark" ma mi da questo errore:

     L’utility non si trova nel tuo PATCH!

    Installala e contatta il tuo amministratore di sistema!

    Bhe non sono molto esperiente di linux anche perchè non ho tanto tempo a disposizione però mi piace quindi ho bisogno dei vostri consigli!! Grazie ancora 

     

  • Il primo errore pare che sia dovuto all’assenza del file nella posizione indicata…

    Ti consiglio innanzi tutto di mettere la versione 2.1.3, cmq se non ho capito male tu hai kubuntu, in tal caso clicca col tasto destro nel file .deb, quindi vai in kubuntu package menu, quindi install… Inserisci la password e vai avanti…